password problem after cloning

Discussions about using Fuel
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
jharris
Posts: 10
Joined: 07 Aug 2015 11:26
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

password problem after cloning

Postby jharris » 02 Sep 2015 14:29

I'm using Fuel 2.0.0Beta3 on Windows 8.1.

After I clone a remote repo and make a change to a file I get this error when trying to commit: "missing or incorrect password for user".

I've tried updating the username/password in the settings window and changing the password via the web UI for the local repo. Nothing seems to correct it.

Would anyone know how to set the correct username/password?

Best Regards,
jharris

Kostas
Posts: 9
Joined: 29 Jul 2015 14:33
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby Kostas » 02 Sep 2015 15:55


jharris
Posts: 10
Joined: 07 Aug 2015 11:26
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby jharris » 02 Sep 2015 21:09

The commit does fail. I get no errors regarding permissions or write errors.

I don't think this happens with 2.0b only though. I tried using all of the 1.0.+ (portable) builds before 2.0b was released and I had the same issue.

If I clone a remote repo with 0.9.6 and then open it with one of the other versions, they work just fine... including 2.0b.

I've only been using Fossil and Fuel for a little longer than a month.

Kostas
Posts: 9
Joined: 29 Jul 2015 14:33
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby Kostas » 04 Sep 2015 10:19

Hi,
Can you run the entire process in a new workspace from clone to the commit failing, and post the complete log in a new ticket?
I would like to try to replicate this issue.
Also can you rename or delete Fuel's settings data in the registry key HKEY_CURRENT_USER\Software\Fuel-SCM\Fuel before trying.

Thanks

jharris
Posts: 10
Joined: 07 Aug 2015 11:26
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby jharris » 04 Sep 2015 10:36

I should have time this afternoon to run Fuel through the process and post the log. If I don't get time today, I'll do it as soon as possible.

jharris
Posts: 10
Joined: 07 Aug 2015 11:26
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby jharris » 04 Sep 2015 13:48


Kostas
Posts: 9
Joined: 29 Jul 2015 14:33
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby Kostas » 05 Sep 2015 11:04


jharris
Posts: 10
Joined: 07 Aug 2015 11:26
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby jharris » 05 Sep 2015 13:04

That seems to have fixed it Kostas. Thank you for the help.

Was this caused by a problem with Fuel or was it a fossil issue?

jharris
Posts: 10
Joined: 07 Aug 2015 11:26
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: password problem after cloning

Postby jharris » 05 Sep 2015 19:47

Just created a new project and repo and it worked just perfect.

Thank you for the help Kostas. I really appreciate it.

JHarris


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “Fuel Users”

Who is online

Users browsing this forum: No registered users and 2 guests